GitHub Advisoryadvisory · Packagist

GHSA-vx9m-rfxq-gr74 Drupal AI Vulnerable to OS Command Injection

MEDIUM Published 2025-04-01 Modified 2025-04-15 Official page ↗
Aliases
CVE-2025-31693
Ecosystem
Packagist
Packages
drupal/ai
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-78
Reviewed
2025-04-02

Affected packages

• Packagist drupal/ai: < 1.0.5 → fixed in 1.0.5

Description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Drupal AI (Artificial Intelligence) allows OS Command Injection. This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.5.

Related

Alias · CVE (1)

  • CVE-2025-31693 Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Drupal AI (Artificial… vulnerability

Weakness · CWE (1)

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References