GitHub Advisoryadvisory · PyPI

GHSA-vxh3-mvv7-265j Cross-site scripting invenio-records

MEDIUM Published 2019-07-16 Modified 2024-09-23 Official page ↗
Aliases
CVE-2019-1020003
Ecosystem
PyPI
Packages
invenio-records
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• PyPI invenio-records: < 1.0.2 → fixed in 1.0.2 • PyPI invenio-records: >= 1.1.0, < 1.1.1 → fixed in 1.1.1 • PyPI invenio-records: >= 1.2.0, < 1.2.2 → fixed in 1.2.2

Description

Cross-Site Scripting (XSS) vulnerability in administration interface Impact A Cross-Site Scripting (XSS) vulnerability was discovered when rendering JSON for a record in the administration interface. The vulnerability could be exploited by e.g. a user who had access to upload a new record, that an admin user would then later view in the admin interface. Patches All supported versions of Invenio-Records have been patched. You should upgrade to either v1.0.1, v1.1.1 or v1.2.2 For more information If you have any questions or comments about this advisory: • Email us at [email protected]

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References