GitHub Advisoryadvisory · Go
GHSA-vxm9-8mfw-vc6g Hermes improperly validates a JWT
HIGH
Official page ↗
- Aliases
- CVE-2025-1293
- Ecosystem
- Go
- Packages
- github.com/hashicorp-forge/hermes
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
- Weaknesses
- CWE-1390
- Reviewed
- 2025-02-20
Affected packages
• Go github.com/hashicorp-forge/hermes: < 0.5.0 → fixed in 0.5.0
Description
Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.
Related
Alias · CVE (1)
- CVE-2025-1293 Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for… vulnerability
Weakness · CWE (1)
- CWE-1390 Weak Authentication weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-1293 advisory
- https://github.com/hashicorp-forge/hermes/commit/e36d479616099bd0c8dfde6786ea671f112d9106 web
- https://discuss.hashicorp.com/t/hcsec-2025-03-hashicorp-hermes-improperly-validates-aws-alb-jwts-which-may-lead-to-authentication-bypass/73371 web
- https://github.com/hashicorp-forge/hermes package