GitHub Advisoryadvisory · Maven
GHSA-vxmh-p52j-h33m Session fixation vulnerability in Jenkins OpenId Connect Authentication Plugin
HIGH
Official page ↗
- Aliases
- CVE-2023-24424
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:oic-auth
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-384
- Reviewed
- 2023-01-27
Affected packages
• Maven org.jenkins-ci.plugins:oic-auth: < 2.5 → fixed in 2.5
Description
Jenkins OpenId Connect Authentication Plugin 2.4 and earlier does not invalidate the previous session on login.
Related
Alias · CVE (1)
- CVE-2023-24424 Jenkins OpenId Connect Authentication Plugin 2.4 and earlier does not invalidate the previous session on login. vulnerability
Weakness · CWE (1)
- CWE-384 Session Fixation weakness