GitHub Advisoryadvisory · Packagist
GHSA-vxr9-p2xw-m8cf Dolibarr remote PHP code execution
CRITICAL
Official page ↗
- Aliases
- CVE-2021-33816
- Ecosystem
- Packagist
- Packages
- dolibarr/dolibarr
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2024-04-24
Affected packages
• Packagist dolibarr/dolibarr: >= 13.0.2, < 14.0.0 → fixed in 14.0.0
Description
The website builder module in Dolibarr 13.0.2 allows remote PHP code execution because of an incomplete protection mechanism in which system, exec, and shell_exec are blocked but backticks are not blocked.
Related
Alias · CVE (1)
- CVE-2021-33816 The website builder module in Dolibarr 13.0.2 allows remote PHP code execution because of an incomplete protection mechanism in which… vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness