GitHub Advisoryadvisory · RubyGems
GHSA-vxvp-4xwc-jpp6 activesupport Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2015-3226
- Ecosystem
- RubyGems
- Packages
- activesupport
- Severity
- Moderate
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• RubyGems activesupport: >= 4.1.0, < 4.1.11 → fixed in 4.1.11
• RubyGems activesupport: >= 4.2.0, < 4.2.2 → fixed in 4.2.2
Description
Cross-site scripting (XSS) vulnerability in `json/encoding.rb` in Active Support in Ruby on Rails 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.
Related
Alias · CVE (1)
- CVE-2015-3226 Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-3226 advisory
- https://github.com/rails/rails package
- https://groups.google.com/forum/message/raw?msg=rubyonrails-security/7VlB_pck3hU/3QZrGIaQW6cJ web
- https://groups.google.com/g/rubyonrails-core/c/qBUqVlXERag/m/kuH3wQk1kxUJ web
- https://web.archive.org/web/20200228033946/http://www.securityfocus.com/bid/75231 web
- https://web.archive.org/web/20200517005133/http://www.securitytracker.com/id/1033755 web
- http://openwall.com/lists/oss-security/2015/06/16/17 web
- http://www.debian.org/security/2016/dsa-3464 web