GitHub Advisoryadvisory · Go
GHSA-w222-m46c-mgh6 OpenFGA Authorization Bypass
MEDIUM
Official page ↗
- Aliases
- CVE-2025-46331
- Ecosystem
- Go
- Packages
- github.com/openfga/openfga
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
- Weaknesses
- CWE-284, CWE-863
- Reviewed
- 2025-04-30
Affected packages
• Go github.com/openfga/openfga: >= 1.3.6, < 1.8.11 → fixed in 1.8.11
Description
Overview
OpenFGA v1.8.10 or previous (Helm chart <= openfga-0.2.28, docker <= v.1.8.10) are vulnerable to authorization bypass when certain Check and ListObject calls are executed.
Am I Affected?
If you are using OpenFGA v1.8.10 or previous, specifically under the following conditions, you are affected by this authorization bypass vulnerability:
• Calling Check API or ListObjects with an authorization model that has tuple cycle.
• Check query cache is enabled, and
• There are multiple check / list objects requests involving the tuple cycle within the check query TTL
Fix
Upgrade to v1.8.11. This upgrade is backwards compatible.
Related
Alias · CVE (1)
- CVE-2025-46331 OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. vulnerability