GitHub Advisoryadvisory · Go

GHSA-w2gr-585j-r428 Metricbeat affected by multiple denial of service vulnerabilities

MEDIUM Published 2026-01-13 Modified 2026-01-22 Official page ↗
Aliases
CVE-2026-0528
Ecosystem
Go
Packages
github.com/elastic/beats/v7
Severity
Moderate
CVSS vector
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-129
Reviewed
2026-01-22

Affected packages

• Go github.com/elastic/beats/v7: < 7.0.0-alpha2.0.20251217054608-6e42552a23ce → fixed in 7.0.0-alpha2.0.20251217054608-6e42552a23ce • Go github.com/elastic/beats/v7: >= 8.0.0, < 8.19.10 → fixed in 8.19.10 • Go github.com/elastic/beats/v7: >= 9.0.0, < 9.1.10 → fixed in 9.1.10 • Go github.com/elastic/beats/v7: >= 9.2.0, < 9.2.4 → fixed in 9.2.4

Description

Improper Validation of Array Index (CWE-129) exists in Metricbeat can allow an attacker to cause a Denial of Service through Input Data Manipulation (CAPEC-153) via specially crafted, malformed payloads sent to the Graphite server metricset or Zookeeper server metricset. Additionally, Improper Input Validation (CWE-20) exists in the Prometheus helper module that can allow an attacker to cause a Denial of Service through Input Data Manipulation (CAPEC-153) via specially crafted, malformed metric data.

Related

Alias · CVE (1)

  • CVE-2026-0528 Improper Validation of Array Index (CWE-129) exists in Metricbeat can allow an attacker to cause a Denial of Service through Input Data… vulnerability

Weakness · CWE (1)

  • CWE-129 Improper Validation of Array Index weakness

References