GitHub Advisoryadvisory · PyPI
GHSA-w2p4-p4rh-qcm3 pgAdmin4 vulnerable to Remote Code Execution (RCE) when running in server mode
CRITICAL
Official page ↗
- Aliases
- CVE-2025-12762
- Ecosystem
- PyPI
- Packages
- pgadmin4
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
- Weaknesses
- CWE-94
- Reviewed
- 2025-11-13
Affected packages
• PyPI pgadmin4: < 9.10 → fixed in 9.10
Description
pgAdmin versions up to 9.9 are affected by a Remote Code Execution (RCE) vulnerability that occurs when running in server mode and performing restores from PLAIN-format dump files. This issue allows attackers to inject and execute arbitrary commands on the server hosting pgAdmin, posing a critical risk to the integrity and security of the database management system and underlying data.
Related
Alias · CVE (1)
- CVE-2025-12762 pgAdmin versions up to 9.9 are affected by a Remote Code Execution (RCE) vulnerability that occurs when running in server mode and… vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness