GitHub Advisoryadvisory · PyPI
GHSA-w2pj-9cgh-mq2c opencv-contrib-python-headless bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863
HIGH
Official page ↗
- Ecosystem
- PyPI
- Packages
- opencv-contrib-python-headless
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-787
- Reviewed
- 2024-08-30
Affected packages
• PyPI opencv-contrib-python-headless: < 4.8.1.78 → fixed in 4.8.1.78
Description
opencv-contrib-python-headless versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. opencv-contrib-python-headless v4.8.1.78 upgrades the bundled libwebp binary to v1.3.2.
Related
Weakness · CWE (1)
- CWE-787 Out-of-bounds Write weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-4863 advisory
- https://github.com/opencv/opencv/pull/24274 web
- https://github.com/opencv/opencv/commit/687fc11626901cff09d2b3b5f331fd59190ad4c7 web
- https://github.com/advisories/GHSA-j7hp-h8jx-5ppr advisory
- https://github.com/opencv/opencv-python package
- https://github.com/opencv/opencv/wiki/ChangeLog#version481 web
- https://github.com/pypa/advisory-database/tree/main/vulns/opencv-contrib-python-headless/PYSEC-2023-182.yaml web