GitHub Advisoryadvisory · PyPI

GHSA-w2v8-php4-p8hc Wagtail has permission check bypass when editing a model with per-field restrictions through `wagtail.contrib.settings` or `ModelViewSet`

LOW Published 2024-05-01 Modified 2024-05-02 Official page ↗
Aliases
CVE-2024-32882
Ecosystem
PyPI
Packages
wagtail
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-280
Reviewed
2024-05-01

Affected packages

• PyPI wagtail: >= 6.0.0, < 6.0.3 → fixed in 6.0.3

Description

Impact If a model has been made available for editing through the `wagtail.contrib.settings` module or `ModelViewSet`, and the `permission` argument on `FieldPanel` has been used to further restrict access to one or more fields of the model, a user with edit permission over the model but not the specific field can craft an HTTP POST request that bypasses the permission check on the individual field, allowing them to update its value. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, or by a user who has not been granted edit access to the model in question. The editing interfaces for pages and snippets are also unaffected. Patches Patched versions have been released as Wagtail 6.0.3 and 6.1. Wagtail releases prior to 6.0 are unaffected. Workarounds Site owners who are unable to upgrade to a patched version can avoid the vulnerability in `ModelViewSet` by registering the model as a snippet instead. No workaround is available for `wagtail.contrib.settings`. Acknowledgements Many thanks to Ben Morse and Joshua Munn for reporting this issue. For more information If you have any questions or comments about this advisory: • Visit Wagtail's support channels • Email us at [email protected] (view our security policy for more information).

Related

Alias · CVE (1)

  • CVE-2024-32882 Wagtail is an open source content management system built on Django. vulnerability

Weakness · CWE (1)

  • CWE-280 Improper Handling of Insufficient Permissions or Privileges weakness

References