GitHub Advisoryadvisory · Packagist

GHSA-w37f-pvvx-wcwm Incorrect Calculation in moodle

CRITICAL Published 2022-05-19 Modified 2022-06-02 Official page ↗
Aliases
CVE-2022-30600
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-682
Reviewed
2022-06-02

Affected packages

• Packagist moodle/moodle: >= 4.0, < 4.0.1 → fixed in 4.0.1 • Packagist moodle/moodle: >= 3.9, < 3.9.14 → fixed in 3.9.14 • Packagist moodle/moodle: >= 3.10, < 3.10.11 → fixed in 3.10.11 • Packagist moodle/moodle: >= 3.11, < 3.11.7 → fixed in 3.11.7

Description

A flaw was found in moodle where logic used to count failed login attempts could result in the account lockout threshold being bypassed.

Related

Alias · CVE (1)

  • CVE-2022-30600 A flaw was found in moodle where logic used to count failed login attempts could result in the account lockout threshold being bypassed. vulnerability

Weakness · CWE (1)

  • CWE-682 Incorrect Calculation weakness

References