GitHub Advisoryadvisory · Packagist

GHSA-w38g-hj45-mjjp Contao SQL injection in the backend and listing module

CRITICAL Published 2022-05-24 Modified 2024-04-25 Official page ↗
Aliases
CVE-2017-16558
Ecosystem
Packagist
Packages
contao/contao, contao/core-bundle, contao/listing-bundle
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2024-04-25

Affected packages

• Packagist contao/contao: >= 3.0.0, <= 3.5.30 (no fix yet) • Packagist contao/contao: >= 4.0.0, < 4.4.8 → fixed in 4.4.8 • Packagist contao/core-bundle: >= 4.0.0, < 4.4.8 → fixed in 4.4.8 • Packagist contao/listing-bundle: >= 4.0.0, < 4.4.8 → fixed in 4.4.8 • Packagist contao/core-bundle: >= 3.0.0, <= 3.5.30 (no fix yet) • Packagist contao/listing-bundle: >= 3.0.0, <= 3.5.30 (no fix yet)

Description

Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the backend as well as in the listing module.

Related

Alias · CVE (1)

  • CVE-2017-16558 Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the back end as well as in the listing module. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References