GitHub Advisoryadvisory · Maven
GHSA-w3f7-2qfw-348x Jenkins HipChat Plugin allows credential capture due to incorrect authorization
HIGH
Official page ↗
- Aliases
- CVE-2018-1000418
- Ecosystem
- Maven
- Packages
- org.jvnet.hudson.plugins:hipchat
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-863
- Reviewed
- 2022-11-22
Affected packages
• Maven org.jvnet.hudson.plugins:hipchat: < 2.2.1 → fixed in 2.2.1
Description
An improper authorization vulnerability exists in Jenkins HipChat Plugin 2.2.0 and earlier in HipChatNotifier.java that allows attackers with Overall/Read access to send test notifications to an attacker-specified HipChat server with attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. As of version 2.2.1, this form validation method requires POST requests and Overall/Administer permissions.
Related
Alias · CVE (1)
- CVE-2018-1000418 An improper authorization vulnerability exists in Jenkins HipChat Plugin 2.2.0 and earlier in HipChatNotifier.java that allows attackers… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness