GitHub Advisoryadvisory · Packagist
GHSA-w3v6-r62r-fvqh Typo3 API XSS Vulnerabilities
MEDIUM
Official page ↗
- Aliases
- CVE-2012-1608
- Ecosystem
- Packagist
- Packages
- typo3/cms
- Severity
- Moderate
- Weaknesses
- CWE-20
- Reviewed
- 2023-08-29
Affected packages
• Packagist typo3/cms: >= 4.4.0, < 4.4.14 → fixed in 4.4.14
• Packagist typo3/cms: >= 4.5.0, < 4.5.14 → fixed in 4.5.14
• Packagist typo3/cms: >= 4.6.0, < 4.6.7 → fixed in 4.6.7
Description
The `t3lib_div::RemoveXSS` API method in TYPO3 4.4.0 through 4.4.13, 4.5.0 through 4.5.13, 4.6.0 through 4.6.6, 4.7, and 6.0 allows remote attackers to bypass the cross-site scripting (XSS) protection mechanism and inject arbitrary web script or HTML via non printable characters.
Related
Alias · CVE (1)
- CVE-2012-1608 The t3lib_div::RemoveXSS API method in TYPO3 4.4.0 through 4.4.13, 4.5.0 through 4.5.13, 4.6.0 through 4.6.6, 4.7, and 6.0 allows remote… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2012-1608 advisory
- https://web.archive.org/web/20120527123559/http://www.securityfocus.com/bid/52771 web
- http://typo3.org/teams/security/security-bulletins/typo3-core/typo3-core-sa-2012-001 web
- http://www.debian.org/security/2012/dsa-2445 web
- http://www.openwall.com/lists/oss-security/2012/03/30/4 web