GitHub Advisoryadvisory · Maven

GHSA-w3w6-26f2-p474 Broken Access Control in Spring Security With Direct Use of isFullyAuthenticated

HIGH Published 2024-02-20 Modified 2025-02-13 Official page ↗
Aliases
CVE-2024-22234
Ecosystem
Maven
Packages
org.springframework.security:spring-security-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-284
Reviewed
2024-02-21

Affected packages

• Maven org.springframework.security:spring-security-core: >= 6.1.0, < 6.1.7 → fixed in 6.1.7 • Maven org.springframework.security:spring-security-core: >= 6.2.0, < 6.2.2 → fixed in 6.2.2

Description

In Spring Security, versions 6.1.x prior to 6.1.7 and versions 6.2.x prior to 6.2.2, an application is vulnerable to broken access control when it directly uses the AuthenticationTrustResolver.isFullyAuthenticated(Authentication) method. Specifically, an application is vulnerable if: • The application uses AuthenticationTrustResolver.isFullyAuthenticated(Authentication) directly and a null authentication parameter is passed to it resulting in an erroneous true return value. An application is not vulnerable if any of the following is true: • The application does not use AuthenticationTrustResolver.isFullyAuthenticated(Authentication) directly. • The application does not pass null to AuthenticationTrustResolver.isFullyAuthenticated • The application only uses isFullyAuthenticated via Method Security https://docs.spring.io/spring-security/reference/servlet/authorization/method-security.html  or HTTP Request Security https://docs.spring.io/spring-security/reference/servlet/authorization/authorize-http-requests.html

Related

Alias · CVE (1)

  • CVE-2024-22234 In Spring Security, versions 6.1.x prior to 6.1.7 and versions 6.2.x prior to 6.2.2, an application is vulnerable to broken access control… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References