GitHub Advisoryadvisory · PyPI

GHSA-w466-2wfc-8g58 Open WebUI has vulnerable dependency on starlette via fastapi

HIGH Published 2025-03-20 Modified 2026-10-26 Official page ↗
Ecosystem
PyPI
Packages
open-webui
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2025-03-21

Affected packages

• PyPI open-webui: < 0.5.8 → fixed in 0.5.8

Description

In version 0.3.32 of open-webui, the application uses a vulnerable version of the starlette package through its dependency on fastapi. The starlette package versions <=0.49 are susceptible to uncontrolled resource consumption, which can be exploited to cause a denial of service through memory exhaustion. This issue is addressed in fastapi version 0.115.3.

Related

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References