GitHub Advisoryadvisory · Maven

GHSA-w4g2-9hj6-5472 Moderate severity vulnerability that affects com.rabbitmq:amqp-client and org.springframework.amqp:spring-amqp

MEDIUM Published 2018-10-18 Modified 2021-09-20 Official page ↗
Aliases
CVE-2018-11087
Ecosystem
Maven
Packages
org.springframework.amqp:spring-amqp, com.rabbitmq:amqp-client
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-295
Reviewed
2020-06-16

Affected packages

• Maven org.springframework.amqp:spring-amqp: >= 2.0.0, < 2.0.6 → fixed in 2.0.6 • Maven org.springframework.amqp:spring-amqp: < 1.7.10 → fixed in 1.7.10 • Maven com.rabbitmq:amqp-client: < 4.8.0 → fixed in 4.8.0 • Maven com.rabbitmq:amqp-client: >= 5.0.0, < 5.4.0 → fixed in 5.4.0

Description

Pivotal Spring AMQP, 1.x versions prior to 1.7.10 and 2.x versions prior to 2.0.6, expose a man-in-the-middle vulnerability due to lack of hostname validation. A malicious user that has the ability to intercept traffic would be able to view data in transit.

Related

Alias · CVE (1)

  • CVE-2018-11087 Pivotal Spring AMQP, 1.x versions prior to 1.7.10 and 2.x versions prior to 2.0.6, expose a man-in-the-middle vulnerability due to lack of… vulnerability

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References