GitHub Advisoryadvisory · Maven
GHSA-w4m2-qmh3-2g8f Yamcs Path Traversal vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2023-45277
- Ecosystem
- Maven
- Packages
- org.yamcs:yamcs
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-22
- Reviewed
- 2023-10-19
Affected packages
• Maven org.yamcs:yamcs: < 5.8.7 → fixed in 5.8.7
Description
Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.
Related
Alias · CVE (1)
- CVE-2023-45277 Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness