GitHub Advisoryadvisory · Packagist

GHSA-w4rc-rx25-8m86 Improper Input Validation in Symfony

CRITICAL Published 2020-02-12 Modified 2021-08-19 Official page ↗
Aliases
CVE-2019-11325
Ecosystem
Packagist
Packages
symfony/symfony, symfony/var-exporter
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-116
Reviewed
2020-02-11

Affected packages

• Packagist symfony/symfony: >= 4.2.0, < 4.2.12 → fixed in 4.2.12 • Packagist symfony/symfony: >= 4.3.0, < 4.3.8 → fixed in 4.3.8 • Packagist symfony/var-exporter: >= 4.2.0, < 4.2.12 → fixed in 4.2.12 • Packagist symfony/var-exporter: >= 4.3.0, < 4.3.8 → fixed in 4.3.8

Description

An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. The VarExport component incorrectly escapes strings, allowing some specially crafted ones to escalate to execution of arbitrary PHP code. This is related to symfony/var-exporter.

Related

Alias · CVE (1)

  • CVE-2019-11325 An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. vulnerability

Weakness · CWE (1)

  • CWE-116 Improper Encoding or Escaping of Output weakness

References