GitHub Advisoryadvisory · npm

GHSA-w54v-hf9p-8856 Parse Server vulnerable to user enumeration via email verification endpoint

MEDIUM Published 2026-03-11 Modified 2026-03-11 Official page ↗
Aliases
CVE-2026-31901
Ecosystem
npm
Packages
parse-server
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-204
Reviewed
2026-03-11

Affected packages

• npm parse-server: >= 9.0.0-alpha.1, < 9.6.0-alpha.8 → fixed in 9.6.0-alpha.8 • npm parse-server: < 8.6.34 → fixed in 8.6.34

Description

Impact The email verification endpoint (`/verificationEmailRequest`) returns distinct error responses depending on whether an email address belongs to an existing user, is already verified, or does not exist. An attacker can send requests with different email addresses and observe the error codes to determine which email addresses are registered in the application. This is a user enumeration vulnerability that affects any Parse Server deployment with email verification enabled (`verifyUserEmails: true`). Patches The fix introduces a new Parse Server option `emailVerifySuccessOnInvalidEmail` (default: `true`) that returns a generic success response for all verification email requests, regardless of whether the email address is valid, already verified, or non-existent. This prevents an attacker from distinguishing between these cases. The fix also strengthens the input validation for the related `resetPasswordSuccessOnInvalidEmail` option, and adds security checks that warn when either enumeration mitigation is disabled. Workarounds There is no known workaround. References • GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-w54v-hf9p-8856 • Fix Parse Server 9: https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.8 • Fix Parse Server 8: https://github.com/parse-community/parse-server/releases/tag/8.6.34

Related

Alias · CVE (1)

  • CVE-2026-31901 Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. vulnerability

Weakness · CWE (1)

  • CWE-204 Observable Response Discrepancy weakness

References