GitHub Advisoryadvisory · npm

GHSA-w573-4hg7-7wgq decode-uri-component vulnerable to Denial of Service (DoS)

HIGH Published 2022-11-28 Modified 2023-03-31 Official page ↗
Aliases
CVE-2022-38900
Ecosystem
npm
Packages
decode-uri-component
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2022-11-28

Affected packages

• npm decode-uri-component: < 0.2.1 → fixed in 0.2.1

Description

decode-uri-component 0.2.0 is vulnerable to Improper Input Validation resulting in DoS.

Related

Alias · CVE (1)

  • CVE-2022-38900 decode-uri-component 0.2.0 is vulnerable to Improper Input Validation resulting in DoS. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References