GitHub Advisoryadvisory · PyPI

GHSA-w578-j992-554x Ansible fails to properly mark lookup-plugin results as unsafe

CRITICAL Published 2018-09-06 Modified 2025-05-29 Official page ↗
Aliases
CVE-2017-7481
Ecosystem
PyPI
Packages
ansible
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• PyPI ansible: >= 2.3.0.0, < 2.3.1.0 → fixed in 2.3.1.0 • PyPI ansible: < 2.1.6.0 → fixed in 2.1.6.0 • PyPI ansible: >= 2.2.0.0, < 2.2.3.0 → fixed in 2.2.3.0

Description

Ansible before versions 2.1.6.0, 2.2.3.0, 2.3.1.0, and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templating language is now marked as 'unsafe' and is not evaluated.

Related

Alias · CVE (1)

  • CVE-2017-7481 Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References