GitHub Advisoryadvisory · Packagist

GHSA-w5fx-cx7f-6vr9 MediaWiki Denial of Service vulnerability

HIGH Published 2023-10-09 Modified 2024-10-30 Official page ↗
Aliases
CVE-2023-45363
Ecosystem
Packagist
Packages
mediawiki/core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-835
Reviewed
2024-10-30

Affected packages

• Packagist mediawiki/core: < 1.35.12 → fixed in 1.35.12 • Packagist mediawiki/core: >= 1.36.0, < 1.39.5 → fixed in 1.39.5 • Packagist mediawiki/core: >= 1.40.0, < 1.40.1 → fixed in 1.40.1

Description

An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set.

Related

Alias · CVE (1)

  • CVE-2023-45363 An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. vulnerability

Weakness · CWE (1)

  • CWE-835 Loop with Unreachable Exit Condition weakness

References