GitHub Advisoryadvisory · PyPI
GHSA-w5gh-2wr2-pm6g Denial of Service in Tensorflow
HIGH
Official page ↗
- Aliases
- CVE-2020-15206
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-cpu, tensorflow-gpu
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2020-09-25
Affected packages
• PyPI tensorflow: < 1.15.4 → fixed in 1.15.4
• PyPI tensorflow: >= 2.0.0, < 2.0.3 → fixed in 2.0.3
• PyPI tensorflow: >= 2.1.0, < 2.1.2 → fixed in 2.1.2
• PyPI tensorflow: >= 2.2.0, < 2.2.1 → fixed in 2.2.1
• PyPI tensorflow: >= 2.3.0, < 2.3.1 → fixed in 2.3.1
• PyPI tensorflow-cpu: < 1.15.4 → fixed in 1.15.4
• PyPI tensorflow-cpu: >= 2.0.0, < 2.0.3 → fixed in 2.0.3
• PyPI tensorflow-cpu: >= 2.1.0, < 2.1.2 → fixed in 2.1.2
• PyPI tensorflow-cpu: >= 2.2.0, < 2.2.1 → fixed in 2.2.1
• PyPI tensorflow-cpu: >= 2.3.0, < 2.3.1 → fixed in 2.3.1
• PyPI tensorflow-gpu: < 1.15.4 → fixed in 1.15.4
• PyPI tensorflow-gpu: >= 2.0.0, < 2.0.3 → fixed in 2.0.3
• PyPI tensorflow-gpu: >= 2.1.0, < 2.1.2 → fixed in 2.1.2
• PyPI tensorflow-gpu: >= 2.2.0, < 2.2.1 → fixed in 2.2.1
• PyPI tensorflow-gpu: >= 2.3.0, < 2.3.1 → fixed in 2.3.1
Description
Impact
Changing the TensorFlow's `SavedModel` protocol buffer and altering the name of required keys results in segfaults and data corruption while loading the model. This can cause a denial of service in products using `tensorflow-serving` or other inference-as-a-service installments.
We have added fixes to this in f760f88b4267d981e13f4b302c437ae800445968 and fcfef195637c6e365577829c4d67681695956e7d (both going into TensorFlow 2.2.0 and 2.3.0 but not yet backported to earlier versions). However, this was not enough, as #41097 reports a different failure mode.
Patches
We have patched the issue in adf095206f25471e864a8e63a0f1caef53a0e3a6 and will release patch releases for all versions between 1.15 and 2.3. Patch releases for versions between 1.15 and 2.1 will also contain cherry-picks of f760f88b4267d981e13f4b302c437ae800445968 and fcfef195637c6e365577829c4d67681695956e7d.
We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Shuaike Dong, from Alipay Tian Qian Security Lab && Lab for Applied Security Research, CUHK.
Related
Alias · CVE (1)
- CVE-2020-15206 In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, changing the TensorFlow's `SavedModel` protocol buffer and altering… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-w5gh-2wr2-pm6g web
- https://nvd.nist.gov/vuln/detail/CVE-2020-15206 advisory
- https://github.com/tensorflow/tensorflow/commit/adf095206f25471e864a8e63a0f1caef53a0e3a6 web
- https://github.com/tensorflow/tensorflow/commit/f760f88b4267d981e13f4b302c437ae800445968 web
- https://github.com/tensorflow/tensorflow/commit/fcfef195637c6e365577829c4d67681695956e7d web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-286.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-321.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-129.yaml web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1 web
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html web