GitHub Advisoryadvisory · Packagist
GHSA-w5h7-mw56-4v7x TastyIgniter Has an Incorrect Access Control Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2024-44314
- Ecosystem
- Packagist
- Packages
- tastyigniter/tastyigniter
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-285
- Reviewed
- 2025-03-21
Affected packages
• Packagist tastyigniter/tastyigniter: < 4.0.0 → fixed in 4.0.0
Description
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
Related
Alias · CVE (1)
- CVE-2024-44314 TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to… vulnerability
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-44314 advisory
- https://github.com/tastyigniter/TastyIgniter package
- https://github.com/tastyigniter/TastyIgniter/blob/3.x/app/admin/controllers/Orders.php web
- https://medium.com/@cnetsec/cve-2024-44314-incorrect-access-control-in-function-updateorder-fc5f2b1b0467 web