GitHub Advisoryadvisory · npm
GHSA-w5hq-hm5m-4548 Cross Site Scripting vulnerability in store2
MEDIUM
Official page ↗
- Aliases
- CVE-2024-57556
- Ecosystem
- npm
- Packages
- store2
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-01-24
Affected packages
• npm store2: < 2.14.4 → fixed in 2.14.4
Description
Cross Site Scripting vulnerability in nbubna store v.2.14.2 and before allows a remote attacker to execute arbitrary code via the store.deep.js component
Related
Alias · CVE (1)
- CVE-2024-57556 Cross Site Scripting vulnerability in nbubna store v.2.14.2 and before allows a remote attacker to execute arbitrary code via the… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness