GitHub Advisoryadvisory · Maven
GHSA-w5m2-299g-rff5 Page Compare Reflected Cross-site Scripting (XSS) vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2022-28820
- Ecosystem
- Maven
- Packages
- com.adobe.acs:acs-aem-commons
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-04-26
Affected packages
• Maven com.adobe.acs:acs-aem-commons: < 5.2.0 → fixed in 5.2.0
Description
Impact
ACS Commons version 5.1.x (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in `/apps/acs-commons/content/page-compare.html` endpoint via the `a` and `b` GET parameters. User input submitted via these parameters is not validated or sanitized.
An attacker must provide a link to someone with access to AEM Author, and could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. The exploitation of this issue requires user interaction in order to be successful.
Patches
This issue has been resolved in 5.2.0.
Workarounds
None
References
N/A
For more information
If you have any questions or comments about this advisory open an issue in acs-aem-commons.
Credit
This issue was discovered and reported by Black Lantern Security.
https://hackerone.com/reports/1466020
Related
Alias · CVE (1)
- CVE-2022-28820 ACS Commons version 5.1.x (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness