GitHub Advisoryadvisory · npm
GHSA-w5pw-gmcw-rfc8 squirrelly Code Injection vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2024-40453
- Ecosystem
- npm
- Packages
- squirrelly
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2024-08-21
Affected packages
• npm squirrelly: >= 9.0.0, < 9.1.0 → fixed in 9.1.0
Description
squirrellyjs squirrelly v9.0.0 was discovered to contain a code injection vulnerability via the component `options.varName`. The issue was fixed in version 9.1.0.
Related
Alias · CVE (1)
- CVE-2024-40453 squirrellyjs squirrelly v9.0.0 and fixed in v.9.0.1 was discovered to contain a code injection vulnerability via the component… vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-40453 advisory
- https://github.com/squirrellyjs/squirrelly/pull/262 web
- https://github.com/squirrellyjs/squirrelly/commit/426f930e5ca1501404cd887071e734ec5feb0bcf web
- https://github.com/squirrellyjs/squirrelly package
- https://samuzora.com/posts/cve-2024-40453 web