GitHub Advisoryadvisory · Packagist
GHSA-w5r2-gvgf-mpm8 Improper Encoding or Escaping of Output and Injection in LibreNMS
HIGH
Official page ↗
- Aliases
- CVE-2019-12463
- Ecosystem
- Packagist
- Packages
- librenms/librenms
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-116, CWE-74
- Reviewed
- 2019-09-25
Affected packages
• Packagist librenms/librenms: >= 1.50.1, < 1.53 → fixed in 1.53
Description
An issue was discovered in LibreNMS 1.50.1. The scripts that handle graphing options (includes/html/graphs/common.inc.php and includes/html/graphs/graphs.inc.php) do not sufficiently validate or encode several fields of user supplied input. Some parameters are filtered with mysqli_real_escape_string, which is only useful for preventing SQL injection attacks; other parameters are unfiltered. This allows an attacker to inject RRDtool syntax with newline characters via the html/graph.php and html/graph-realtime.php scripts. RRDtool syntax is quite versatile and an attacker could leverage this to perform a number of attacks, including disclosing directory structure and filenames, disclosing file content, denial of service, or writing arbitrary files. NOTE, relative to CVE-2019-10665, this requires authentication and the pathnames differ.
Related
Alias · CVE (1)
- CVE-2019-12463 An issue was discovered in LibreNMS 1.50.1. vulnerability