GitHub Advisoryadvisory · Maven
GHSA-w5v7-q2j4-fvpf Jenkins Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2015-1812
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- Weaknesses
- CWE-79
- Reviewed
- 2024-03-12
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 1.596.2 → fixed in 1.596.2
• Maven org.jenkins-ci.main:jenkins-core: >= 1.600, < 1.606 → fixed in 1.606
Description
Cross-site scripting (XSS) vulnerability in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors, a different vulnerability than CVE-2015-1813.
Related
Alias · CVE (1)
- CVE-2015-1812 Cross-site scripting (XSS) vulnerability in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to inject arbitrary web… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-1812 advisory
- https://github.com/jenkinsci/jenkins/commit/f58ba6e72f978e2f73299e38a1b54ff70fc73fd8 web
- https://github.com/jenkinsci/jenkins/commit/f880d8d2cd9d46987ee3630fa04f77b17784f4e8 web
- https://github.com/jenkinsci/jenkins/commit/feb2703adb0c121705e5c8e9ddf8f663b6481cbd web
- https://access.redhat.com/errata/RHSA-2016:0070 web
- https://bugzilla.redhat.com/show_bug.cgi?id=1205615 web
- https://github.com/jenkinsci/jenkins package
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-03-23 web
- http://rhn.redhat.com/errata/RHSA-2015-1844.html web