GitHub Advisoryadvisory · PyPI
GHSA-w65c-cmxj-qrhm Wooey has an Incorrect Privilege Assignment issue
LOW
Official page ↗
- Aliases
- CVE-2026-7142
- Ecosystem
- PyPI
- Packages
- wooey
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-266
- Reviewed
- 2026-05-06
Affected packages
• PyPI wooey: < 0.13.3rc1 → fixed in 0.13.3rc1
Description
A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function add_or_update_script of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.
Related
Alias · CVE (1)
- CVE-2026-7142 A vulnerability was determined in Wooey up to 0.13.2. vulnerability
Weakness · CWE (1)
- CWE-266 Incorrect Privilege Assignment weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-7142 advisory
- https://github.com/wooey/Wooey/issues/408 web
- https://github.com/wooey/Wooey/pull/407 web
- https://github.com/wooey/Wooey/commit/f7846fc0c323da8325422cab32623491757f1b88 web
- https://github.com/wooey/Wooey package
- https://github.com/wooey/Wooey/releases/tag/v0.13.3rc1 web
- https://vuldb.com/submit/801533 web
- https://vuldb.com/vuln/359741 web
- https://vuldb.com/vuln/359741/cti web