GitHub Advisoryadvisory · Packagist
GHSA-w68r-5p45-5rqp Improper Input Validation in Laravel
HIGH
Official page ↗
- Aliases
- CVE-2020-24941
- Ecosystem
- Packagist
- Packages
- laravel/framework
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2021-05-04
Affected packages
• Packagist laravel/framework: < 6.18.35 → fixed in 6.18.35
• Packagist laravel/framework: >= 7.0.0, < 7.24.0 → fixed in 7.24.0
Description
An issue was discovered in Laravel before 6.18.35 and 7.x before 7.24.0. The $guarded property is mishandled in some situations involving requests with JSON column nesting expressions.
Related
Alias · CVE (1)
- CVE-2020-24941 An issue was discovered in Laravel before 6.18.35 and 7.x before 7.24.0. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness