GitHub Advisoryadvisory · PyPI

GHSA-w6c7-j32f-rq8j Apache Superset Allows Ownership Takeover

MEDIUM Published 2025-05-13 Modified 2025-07-16 Official page ↗
Aliases
CVE-2025-27696
Ecosystem
PyPI
Packages
apache-superset
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-285, CWE-863
Reviewed
2025-05-13

Affected packages

• PyPI apache-superset: < 4.1.2 → fixed in 4.1.2

Description

Improper Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions. This issue affects Apache Superset: through 4.1.1. Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2025-27696 Incorrect Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users… vulnerability

Weakness · CWE (2)

  • CWE-285 Improper Authorization weakness
  • CWE-863 Incorrect Authorization weakness

References