GitHub Advisoryadvisory · Go

GHSA-w6hh-w36c-vxmw LocalAI Cross-Site Scripting (XSS) vulnerability in its search functionality

MEDIUM Published 2025-03-20 Modified 2025-03-21 Official page ↗
Aliases
CVE-2024-9900
Ecosystem
Go
Packages
github.com/mudler/LocalAI
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weaknesses
CWE-115, CWE-79
Reviewed
2025-03-21

Affected packages

• Go github.com/mudler/LocalAI: < 2.22.0 → fixed in 2.22.0

Description

mudler/localai version v2.21.1 contains a Cross-Site Scripting (XSS) vulnerability in its search functionality. The vulnerability arises due to improper sanitization of user input, allowing the injection and execution of arbitrary JavaScript code. This can lead to the execution of malicious scripts in the context of the victim's browser, potentially compromising user sessions, stealing session cookies, redirecting users to malicious websites, or manipulating the DOM.

Related

Alias · CVE (1)

  • CVE-2024-9900 mudler/localai version v2.21.1 contains a Cross-Site Scripting (XSS) vulnerability in its search functionality. vulnerability

Weakness · CWE (2)

  • CWE-115 Misinterpretation of Input weakness
  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References