GitHub Advisoryadvisory · RubyGems

GHSA-w6pv-c757-6rgr apollo_upload_server has Denial of Service vulnerability

MEDIUM Published 2022-05-24 Modified 2023-03-17 Official page ↗
Aliases
CVE-2021-39880
Ecosystem
RubyGems
Packages
apollo_upload_server
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Reviewed
2023-03-17

Affected packages

• RubyGems apollo_upload_server: < 2.1.0 → fixed in 2.1.0

Description

A Denial Of Service vulnerability in the apollo_upload_server Ruby gem in GitLab CE/EE version 11.11 and above allows an attacker to deny access to all users via specially crafted requests to the apollo_upload_server middleware.

Related

Alias · CVE (1)

  • CVE-2021-39880 A Denial Of Service vulnerability in the apollo_upload_server Ruby gem in GitLab CE/EE all versions starting from 11.9 before 14.0.9, all… vulnerability

References