GitHub Advisoryadvisory · Maven
GHSA-w73q-mc9g-j56x Asset Pipeline Grails Plugin vulnerable to Path Traversal
HIGH
Official page ↗
- Aliases
- CVE-2018-1000817
- Ecosystem
- Maven
- Packages
- org.grails.plugins:asset-pipeline
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-22
- Reviewed
- 2022-11-22
Affected packages
• Maven org.grails.plugins:asset-pipeline: < 2.14.1 → fixed in 2.14.1
• Maven org.grails.plugins:asset-pipeline: >= 2.15.0, < 2.15.1 → fixed in 2.15.1
• Maven org.grails.plugins:asset-pipeline: >= 3.0.0, < 3.0.6 → fixed in 3.0.6
Description
Asset Pipeline Grails Plugin Asset-pipeline plugin version Prior to 2.14.1.1, 2.15.1 and 3.0.6 contains a Incorrect Access Control vulnerability in Applications deployed in Jetty that can result in Download .class files and any arbitrary file. This attack appear to be exploitable via Specially crafted GET request containing directory traversal from assets-pipeline context. This vulnerability appears to have been fixed in 2.14.1.1 (for Grails 2.x), 2.15.1 (for Grails 3 and Java 7) and 3.0.6 (for Grails 3 and Java 8).
Related
Alias · CVE (1)
- CVE-2018-1000817 Asset Pipeline Grails Plugin Asset-pipeline plugin version Prior to 2.14.1.1, 2.15.1 and 3.0.6 contains a Incorrect Access Control… vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness