GitHub Advisoryadvisory · NuGet
GHSA-w7cw-xp7h-6j5j Microsoft Security Advisory CVE-2026-50524 – .NET Denial of Service Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2026-50524
- Ecosystem
- NuGet
- Packages
- Microsoft.NetCore.App.Runtime.linux-arm, Microsoft.NetCore.App.Runtime.linux-arm64, Microsoft.NetCore.App.Runtime.linux-musl-arm, Microsoft.NetCore.App.Runtime.linux-musl-arm64, Microsoft.NetCore.App.Runtime.linux-musl-x64, Microsoft.NetCore.App.Runtime.linux-x64, Microsoft.NetCore.App.Runtime.osx-arm64, Microsoft.NetCore.App.Runtime.osx-x64, Microsoft.NetCore.App.Runtime.win-arm, Microsoft.NetCore.App.Runtime.win-arm64, Microsoft.NetCore.App.Runtime.win-x64, Microsoft.NetCore.App.Runtime.win-x86
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1287
- Reviewed
- 2026-07-20
Affected packages
• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
Description
Executive summary
Microsoft is releasing this security advisory to provide information about a vulnerability in .NET TLS/SSL (System.Net.Security). This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability.
A denial of service vulnerability exists in .NET 8, .NET 9, and .NET 10 when processing TLS handshakes. An attacker can send a malformed request and cause application to crash or become unresponsive.
Announcement
Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/TBD
CVSS Details
• Version: 3.1
• Severity: High
• Score: 7.5
• Vector: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C`
• Weakness: CWE-1287 (Improper Validation of Specified Type of Input)
Affected Platforms
• Platforms: All
• Architectures: All
Affected Packages
The vulnerability affects any Microsoft .NET project if it uses any of affected package versions listed below
.NET 10.0
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.NetCore.App.Runtime.linux-arm | >= 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, .NET 9.0
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.NetCore.App.Runtime.linux-arm | >= 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, .NET 8.0
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.NetCore.App.Runtime.linux-arm | >= 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, How do I know if I am affected?
If using a package listed in affected packages, you're exposed to the vulnerability.
How do I fix the issue?
1. To fix the issue please install the latest version of .NET. If you have installed one or more .NET SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET SDKs.
2. If your application references the vulnerable nuget package, update the package reference to the patched version. You can list the versions you have installed by running the `dotnet --info` command.
Once you have installed the updated runtime or SDK, restart you…
Related
Alias · CVE (1)
- CVE-2026-50524 Improper validation of specified type of input in .NET Framework allows an unauthorized attacker to deny service over a network. vulnerability
Weakness · CWE (1)
- CWE-1287 Improper Validation of Specified Type of Input weakness
References
- https://github.com/dotnet/runtime/security/advisories/GHSA-w7cw-xp7h-6j5j web
- https://nvd.nist.gov/vuln/detail/CVE-2026-50524 advisory
- https://github.com/dotnet/announcements/issues/413 web
- https://github.com/dotnet/runtime/issues/130710 web
- https://github.com/dotnet/runtime package
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2026-50524 web