GitHub Advisoryadvisory · Packagist

GHSA-w7rg-7wq2-pjrw Magento Open Source Improper Access Control vulnerability

LOW Published 2024-10-10 Modified 2024-12-12 Official page ↗
Aliases
CVE-2024-45149
Ecosystem
Packagist
Packages
magento/community-edition
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-284
Reviewed
2024-10-11

Affected packages

• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p3 → fixed in 2.4.7-p3 • Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p8 → fixed in 2.4.6-p8 • Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p10 → fixed in 2.4.5-p10 • Packagist magento/community-edition: < 2.4.4-p11 → fixed in 2.4.4-p11 • Packagist magento/community-edition: 2.4.7 (no fix yet) • Packagist magento/community-edition: 2.4.6 (no fix yet) • Packagist magento/community-edition: 2.4.5 (no fix yet) • Packagist magento/community-edition: 2.4.4 (no fix yet)

Description

Magento Open Source versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. A high-privileged attacker could leverage this vulnerability to bypass security measures and have a low impact on confidentiality. Exploitation of this issue does not require user interaction.

Related

Alias · CVE (1)

  • CVE-2024-45149 Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Improper Access Control vulnerability that… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References