GitHub Advisoryadvisory · PyPI

GHSA-w8p5-mx5w-cpqj ansible-core: Argument injection in ansible-galaxy role install leads to arbitrary code execution

HIGH Published 2026-06-05 Modified 2026-07-16 Official page ↗
Aliases
CVE-2026-11332
Ecosystem
PyPI
Packages
ansible-core
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-88
Reviewed
2026-07-16

Affected packages

• PyPI ansible-core: < 2.16.19rc1 → fixed in 2.16.19rc1 • PyPI ansible-core: >= 2.17.0b1, < 2.18.18rc1 → fixed in 2.18.18rc1 • PyPI ansible-core: >= 2.19.0b1, < 2.19.11rc1 → fixed in 2.19.11rc1 • PyPI ansible-core: >= 2.20.0b1, < 2.20.7rc1 → fixed in 2.20.7rc1 • PyPI ansible-core: >= 2.21.0b1, < 2.21.1rc1 → fixed in 2.21.1rc1

Description

A flaw was found in ansible-core. The ansible-galaxy role install command processes dependency specifications from a role's meta/requirements.yml file. Due to improper neutralization of argument delimiters, a malicious role author can inject arbitrary git configuration flags through the src field. This allows arbitrary code execution on the machine of a user who installs the role via ansible-galaxy role install.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-88 Improper Neutralization of Argument Delimiters in a Command weakness

References