GitHub Advisoryadvisory · Packagist
GHSA-w969-pq6x-267j INTER-Mediator Cross-Site Scripting (XSS)
MEDIUM
Official page ↗
- Aliases
- CVE-2017-6484
- Ecosystem
- Packagist
- Packages
- inter-mediator/inter-mediator
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-24
Affected packages
• Packagist inter-mediator/inter-mediator: >= 5.5, < 5.6 → fixed in 5.6
Description
Multiple Cross-Site Scripting (XSS) issues were discovered in INTER-Mediator 5.5. The vulnerabilities exist due to insufficient filtration of user-supplied data (c and cred) passed to the "INTER-Mediator-master/Auth_Support/PasswordReset/resetpassword.php" URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
Related
Alias · CVE (1)
- CVE-2017-6484 Multiple Cross-Site Scripting (XSS) issues were discovered in INTER-Mediator 5.5. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness