GitHub Advisoryadvisory · Maven
GHSA-w9gq-8q35-3jcc Jenkins Subversion Plugin Incorrect Authorization vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000111
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:subversion
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2022-12-07
Affected packages
• Maven org.jenkins-ci.plugins:subversion: < 2.10.3 → fixed in 2.10.3
Description
An improper authorization vulnerability exists in Jenkins Subversion Plugin version 2.10.2 and earlier in `SubversionStatus.java` and `SubversionRepositoryStatus.java` that allows an attacker with network access to obtain a list of nodes and users. As of version 2.10.3, the class handling requests to /subversion/ no longer extends the class handling requests to the …/search/ sub-path, therefore any such requests will fail.
Related
Alias · CVE (1)
- CVE-2018-1000111 An improper authorization vulnerability exists in Jenkins Subversion Plugin version 2.10.2 and earlier in SubversionStatus.java and… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness