GitHub Advisoryadvisory · npm

GHSA-w9hm-4m3m-fxmm ngx-extended-pdf-viewer bundles a version of pdf.js vulnerable to CVE-2026-16633

HIGH Published 2026-08-06 Modified 2026-08-06 Official page ↗
Ecosystem
npm
Packages
ngx-extended-pdf-viewer
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-1103
Reviewed
2026-08-06

Affected packages

• npm ngx-extended-pdf-viewer: >= 27.0.0-rc.0, < 29.0.0-rc.3 → fixed in 29.0.0-rc.3

Description

ngx-extended-pdf-viewer embeds a fork of Mozilla's pdf.js rather than depending on pdfjs-dist, so this vulnerability is not visible to dependency scanners through package.json. Impact Opening a malicious PDF can execute attacker-controlled JavaScript in the context of the hosting page. Upstream advisory: GHSA-hq66-cqwq-w95j / CVE-2026-16633. Exposure. The sandbox half of the issue requires enableScripting, which pdf.js enables by default but this library does not — so the default configuration was less exposed than upstream's. The other half concerns XFA rich text and is reachable whenever enableXfa is true, which is the default here. Do not assume the default configuration was safe. Patches 29.0.0-rc.3 cherry-picks Mozilla's fix (pdf.js 6.2.108) into both the stable and bleeding-edge engines. Only the latest release receives security updates. Workarounds Set pdfDefaultOptions.enableXfa = false if you do not need XFA forms, and/or apply a CSP disallowing inline script-src. Verifying. From 29.0.0 the package ships sbom.json and vex.json. The SBOM records the applied fix as a CycloneDX pedigree.patches entry; the VEX carries a resolved_with_pedigree statement so scanners stop flagging the engine's nominal version.

Related

Weakness · CWE (1)

  • CWE-1103 Use of Platform-Dependent Third Party Components weakness

References