GitHub Advisoryadvisory · npm, NuGet, Packagist, PyPI

GHSA-w9jx-4g6g-rp7x TinyMCE Cross-Site Scripting (XSS) vulnerability using noscript elements

MEDIUM Published 2024-06-19 Modified 2024-07-05 Official page ↗
Aliases
CVE-2024-38357
Ecosystem
npm, NuGet, Packagist, PyPI
Packages
tinymce, TinyMCE, tinymce/tinymce, django-tinymce
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-06-19

Affected packages

• npm tinymce: < 5.11.0 → fixed in 5.11.0 • NuGet TinyMCE: < 5.11.0 → fixed in 5.11.0 • Packagist tinymce/tinymce: < 5.11.0 → fixed in 5.11.0 • npm tinymce: >= 6.0.0, < 6.8.4 → fixed in 6.8.4 • npm tinymce: >= 7.0.0, < 7.2.0 → fixed in 7.2.0 • NuGet TinyMCE: >= 6.0.0, < 6.8.4 → fixed in 6.8.4 • NuGet TinyMCE: >= 7.0.0, < 7.2.0 → fixed in 7.2.0 • Packagist tinymce/tinymce: >= 6.0.0, < 6.8.4 → fixed in 6.8.4 • Packagist tinymce/tinymce: >= 7.0.0, < 7.2.0 → fixed in 7.2.0 • PyPI django-tinymce: < 4.1.0 → fixed in 4.1.0

Description

Impact A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor. Patches This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that content within noscript elements are properly parsed. Fix To avoid this vulnerability: • Upgrade to TinyMCE 7.2.0 or higher. • Upgrade to TinyMCE 6.8.4 or higher for TinyMCE 6.x. • Upgrade to TinyMCE 5.11.0 LTS or higher for TinyMCE 5.x (only available as part of commercial long-term support contract). Acknowledgements Tiny thanks Malav Khatri and another reporter for their help identifying this vulnerability. References • TinyMCE 6.8.4 • TinyMCE 7.2.0 For more information If you have any questions or comments about this advisory: • Email us at [email protected] • Open an issue in the TinyMCE repo

Related

Alias · CVE (1)

  • CVE-2024-38357 TinyMCE is an open source rich text editor. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References