GitHub Advisoryadvisory · npm

GHSA-w9m9-85wc-3x92 postcss-selector-parser allows denial of service through uncontrolled AST recursion

LOW Published 2026-05-26 Modified 2026-09-01 Official page ↗
Aliases
CVE-2026-9358
Ecosystem
npm
Packages
postcss-selector-parser
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Weaknesses
CWE-404
Reviewed
2026-09-01

Affected packages

• npm postcss-selector-parser: >= 6.1.0, < 6.1.3 → fixed in 6.1.3 • npm postcss-selector-parser: >= 7.1.0, < 7.1.3 → fixed in 7.1.3

Description

A vulnerability was determined in postcss-selector-parser before 6.1.3 and 7.1.1. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. The vendor explains, that according to his definition "DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS)."

Related

Alias · CVE (1)

  • CVE-2026-9358 A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2. vulnerability

Weakness · CWE (1)

  • CWE-404 Improper Resource Shutdown or Release weakness

References