GitHub Advisoryadvisory · Packagist

GHSA-w9ph-q4h9-rwq6 CodeIgniter and Kohana vulnerable to PHP Object Injection

CRITICAL Published 2022-05-17 Modified 2023-08-16 Official page ↗
Aliases
CVE-2014-8684
Ecosystem
Packagist
Packages
codeigniter/framework, kohana/core
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Reviewed
2023-08-16

Affected packages

• Packagist codeigniter/framework: < 3.0.0 → fixed in 3.0.0 • Packagist kohana/core: < 3.3.3 → fixed in 3.3.3

Description

CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies and consequently conduct PHP object injection attacks by leveraging use of standard string comparison operators to compare cryptographic hashes.

Related

Alias · CVE (1)

  • CVE-2014-8684 CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies… vulnerability

References