GitHub Advisoryadvisory · Maven

GHSA-wcgx-2hvx-5cwr Apache Struts Cross-site Scripting vulnerability

MEDIUM Published 2022-05-01 Modified 2024-02-09 Official page ↗
Aliases
CVE-2008-2025
Ecosystem
Maven
Packages
struts:struts
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2024-02-09

Affected packages

• Maven struts:struts: < 1.2.9-162.31.1 → fixed in 1.2.9-162.31.1

Description

Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on SUSE openSUSE 10.3, before 1.2.9-198.2 on SUSE openSUSE 11.0, and before 1.2.9-162.163.2 on SUSE openSUSE 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to "insufficient quoting of parameters."

Related

Alias · CVE (1)

  • CVE-2008-2025 Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References