GitHub Advisoryadvisory · Packagist

GHSA-wcmm-28rg-mg3r phpMyAdmin allows remote attackers to obtain installation path via direct request for nonexistent file

MEDIUM Published 2022-05-17 Modified 2025-04-12 Official page ↗
Aliases
CVE-2011-0986
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Moderate
Weaknesses
CWE-20, CWE-22
Reviewed
2025-04-12

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 2.11.0, < 2.11.11.2 → fixed in 2.11.11.2 • Packagist phpmyadmin/phpmyadmin: >= 3.3.0, < 3.3.9.1 → fixed in 3.3.9.1

Description

phpMyAdmin 2.11.x before 2.11.11.2, and 3.3.x before 3.3.9.1, does not properly handle the absence of the (1) README, (2) ChangeLog, and (3) LICENSE files, which allows remote attackers to obtain the installation path via a direct request for a nonexistent file.

Related

Alias · CVE (1)

  • CVE-2011-0986 phpMyAdmin 2.11.x before 2.11.11.2, and 3.3.x before 3.3.9.1, does not properly handle the absence of the (1) README, (2) ChangeLog, and… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References