GitHub Advisoryadvisory · Maven

GHSA-wf76-qgqq-gcfj RCE vulnerability in Google Kubernetes Engine Plugin

HIGH Published 2022-05-24 Modified 2023-01-14 Official page ↗
Aliases
CVE-2020-2121
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:google-kubernetes-engine
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2023-01-14

Affected packages

• Maven org.jenkins-ci.plugins:google-kubernetes-engine: < 0.8.1 → fixed in 0.8.1

Description

Google Kubernetes Engine Plugin 0.8.0 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution vulnerability exploitable by users able to provide YAML input files to Google Kubernetes Engine Plugin’s build step. Google Kubernetes Engine Plugin 0.8.1 configures its YAML parser to only instantiate safe types.

Related

Alias · CVE (1)

  • CVE-2020-2121 Jenkins Google Kubernetes Engine Plugin 0.8.0 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References