GitHub Advisoryadvisory · npm

GHSA-wfm2-rq5g-f8v5 @account-kit/smart-contracts Allowlist Module Bypass Vulnerability

MEDIUM Published 2025-04-29 Modified 2025-04-29 Official page ↗
Ecosystem
npm
Packages
@account-kit/smart-contracts
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
Weaknesses
CWE-288
Reviewed
2025-04-29

Affected packages

• npm @account-kit/smart-contracts: >= 4.8.0, < 4.28.2 → fixed in 4.28.2

Description

Summary Allowlist module contains a bypass vulnerability Details The logic for using an allowlist on a Modular Account V2 contained a bug that allowed session keys to bypass any allowlist configuration Action If you are using @aa-sdk and/or @account-kit/smart-contracts between the versions of >=4.8.0 and <4.28.1, please upgrade to 4.28.2

Related

Weakness · CWE (1)

  • CWE-288 Authentication Bypass Using an Alternate Path or Channel weakness

References